Another Electronic Throttle Control (ETC) Problem - Ram 1500 Diesel Forum
 
LinkBack Thread Tools
post #1 of 8 Old 03-15-2015, 08:37 PM Thread Starter
Junior Member
 
Join Date: Mar 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Another Electronic Throttle Control (ETC) Problem

With just 1200 miles on the new truck, I started a steep grade and the truck would only go up at 16 miles per hour....After trying to lower gears, nothing helped...Got every red symbol, and "service electronic throttle control"....Ending towing vehicle back to my business a 100 miles later....Restarting the truck and it seemed to be OK....Will go to the dealer Monday.......Seems like these ETC modules are acting up with quite a few owners, each displaying different failures........Anyone with the problem have it solved by Service satisfactorily?????? or know what is going on????? I never owned a new Ford truck and had problems with such low mileage....Beginning to think the 2014 owners will be the guinea pigs for the Ecodiesel.......What do you guys think?????

I checked for recalls, and Ram stated no significant recalls.........
cobramustang1993 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 03-27-2015, 07:15 AM
Junior Member
 
Join Date: Mar 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thumbs down

I too have the same message. ED truck is 3 months old. The check engine light as well as the Service Electronic Throttle Control lights are on and the truck will not go passed 2nd gear. Guess I am going to have to get it towed to the closest dealer. Hope this is a quick fix. I have read that it may be just a programming problem.
scubedivr is offline  
post #3 of 8 Old 03-27-2015, 07:41 AM
Junior Member
 
Join Date: Mar 2015
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Angry

I too got the same problem. Check engine light....Electronic Throttle Control symbol lit up and it will not go past 2nd gear automatically or manually. Going to have to be towed to the shop. Hoping it is a quick programming fix.
scubedivr is offline  
 
post #4 of 8 Old 03-27-2015, 10:51 AM
Senior Member
 
zoomie's Avatar
 
Join Date: Jul 2014
Location: Hamilton Ontario
Posts: 477
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by cobramustang1993 View Post
With just 1200 miles on the new truck, I started a steep grade and the truck would only go up at 16 miles per hour. I never owned a new Ford truck and had problems with such low mileage
I'm a little confused, is this a RAM or a Ford you are talking about?

Whatever it is, the dealer is the place to go and we would love to hear about the resolution.

2014 1500 EcoDiesel Outdoorsman, Cherry Red, Backup Camera, Limited Slip Diff, Remote Start, Bed Liner, Side Steps, Rear Window Defroster, Undercover Flex, Weathertech Mats, Husky Mud Flaps
zoomie is offline  
post #5 of 8 Old 03-31-2015, 05:28 PM
Member
 
ECO33's Avatar
 
Join Date: Nov 2014
Location: Oregon in the summer and Washington in the winter.
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Etc

Anytime you touch the break pedal when foot is on the fuel pedal you will get the warning. It confuses the computer ( go forward of stop ) it does not know what you want to do.It happened to me with less than 50 miles on the truck. Pulled over to the side of the road, shut it down for a few minutes and it started and run fine. Took it to the dealer the next day and it was okay, The print out from their system said just that, Keep both feet of the controls at the same time. I now have 9850 miles on the truck and every so often I get that fast warning but never goes in the limp mode.
ECO33 is offline  
post #6 of 8 Old 05-19-2015, 12:03 AM
Junior Member
 
Join Date: May 2014
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not happy with my Ram

My 11 month old ED with 18000 miles on it gave me a Check Engine Light and Service Electronic Throttle Control message. I didn't touch the brake. It went into Limp Mode, staying in 2nd or 3rd and governing itself to 3000 RPM. A call to roadside assistance got Ram to pay for a tow to the Nearest Dealer. Not my dealer, one that I quit doing business with 10 years ago. Ram would allow me to take it to my dealer, an additional 40 miles away, if I paid $216 for the tow. So it went to the "nearest" dealer. Wednesday, the day it left me walking, they called and said it needed an Exhaust Temp Sensor and they would order it and get it installed on Friday. Friday I found they had ordered the wrong part blaming an "unclear" parts book. No loaner from the "Nearest" dealer so I cancelled my weekend plans to go camping. They took the part off and got a part number and ordered the right sensor. Monday I got it back and it seems fine. This ED is my very first MoPar product in 60+ years of running Ford and GM. I trade pickups every 2-3 years never getting more than about 70K miles on one. I've had a few recall issues easily taken care of during those decades, but never had a pickup hauled off by a tow truck. I never bought Chrysler/Dodge/Ram in the past because I felt quality was suspect. I was right. I've lost trust in my vehicle wondering "what next?" Too bad, I really like the ED but for $56,000 I expect my new pickup to get me home.... always did before I bought a Ram.
Ryanlaw is offline  
post #7 of 8 Old 05-20-2015, 09:04 AM
Junior Member
 
Join Date: Aug 2014
Location: Islip, NY
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Has anyone had their problems escalated to the lemon Law Division of Ram? I have had the same problem over 10 times, and weeks down. Fuel Rail pressure senor. The senor has been replaced twice, Harness replaced, new computer, and keeps popping code. Ram advised yesterday, that they are escalating my case to the Lemon Law buy back section. Has anyone gone through this?
Nick956 is offline  
post #8 of 8 Old 07-19-2016, 10:11 AM
Junior Member
 
Join Date: Jul 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Nick how did that work out, this is what has happened to me so far. In the past three months this light has come on 4 times. When it does I lose power and three times now I have had it towed in. I learned my lesson from trying to limp it to the dealer, too many close calls since you can't move out of the way for anything. This last instance I was in traffic, we slowed down for someone to turn off the road, traffic then accelerated, I attempted to with no power, looking down I saw the ETC light on again, when I looked up, a car was bearing down on me from behind. I could not do anything quickly except hit the flasher button, and they went around me. This issue has become a hazard to my safety and anyone else around me, or riding with me. My wife refuses to ride in the vehicle. I know I have hit the requirements for the lemon law, 4 times same issue in 3 months, vehicle down for over thirty days in 3 months. What do I do now? Dealer just wants to try and fix it again. Obviously no one knows what to do. 2016/1500 ecodiesel, 13500 miles, only had it 9 months.
1SG Retired is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Service Electronic Throttle Control" Message Lubiniecki Ram 1500 EcoDiesel General Discussion 6 02-24-2015 01:33 PM
Service Electronic Throttle Control?? HVAC Man Ram 1500 EcoDiesel General Discussion 9 02-06-2015 04:47 PM
ECT problem fatpapa New Member Introductions 0 12-25-2014 09:34 AM
Major fuel problem tgilbert642 2014+ Ram 1500 EcoDiesel Troubleshooting 13 11-19-2014 08:57 AM
1st Problem at 9 days old...Washer Fluid Leak Snowpig2u 2014+ Ram 1500 EcoDiesel Troubleshooting 18 06-28-2014 11:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome