Exhaust System Maintenance Required and Service Electronic Throttle Control - Ram 1500 Diesel Forum
 
LinkBack Thread Tools
post #1 of 2 Old 03-09-2018, 12:00 AM Thread Starter
Junior Member
 
Join Date: Mar 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Exhaust System Maintenance Required and Service Electronic Throttle Control

I recently installed GDE tune( I am on my 2nd tank of fuel MPG'S went up 6.5 mpgs). With that being said I started my truck to go to work temp outside was mid 50's. Within 1/4 mile check engine light came on along with Exhaust system service required see dealer and service elec throttle. Checked code it was p0546 exhaust gas temperature sensor circuit high bank 1. This code is permament, confirmed, and pending. I ordered a new exhaust gas temp sensor and replaced it. The sensor I replaced was located center top of the motor at the firewall. I had to remove the engine cover, air filter cover, and the air tube to access the sensor. The sensor has a built in 2 post connector attached to it so I just disconnect the pigtail from the old one installed new one and plugged it back in. I can not reset the check engine light nor can I get it out of limp mode. My question(s) are did I replace the right sensor? I know there are several sensors on the exhaust pipe. I have searched high and low for a repair manual to no avail. I can find them for every engine except the 3.0L ecodiesel. What are my options to reset everything to verify I changed the right sensor. With the code being permanent and in limp mode is it going to take a scan tool from dealership? Any chances it has anything to do with my ECU I got from GDE. I have never had a problem with my truck like this and I have 82K on it. As I previously stated I am only on my 2nd tank of fuel since the tune installed. Coincidence? Any help is greatly appreciated. The closest dealership is 45 miles away so I would love to keep from trying to limp in there. I have the negative batt terminal disconnected along with both of the harnesses that plug into the ECU. I am going to leave it like that over night and try to see if it clears itself otw to work. Thanks in advance!
stanzi is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-09-2018, 01:40 PM Thread Starter
Junior Member
 
Join Date: Mar 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I have been speaking with GDE about my issues as well and they have been very helpful also. Like I previously stated while the truck was running it was alot more responsive and I did see 6.5 MPG increase. I think it is just coincidental my problem came
stanzi is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Service Electronic Throttle Control" Message Lubiniecki Ram 1500 EcoDiesel General Discussion 7 05-29-2018 05:27 PM
Electronic Throttle Control Service light 1SG Retired 2014+ Ram 1500 EcoDiesel Troubleshooting 3 05-15-2018 07:07 AM
Service Electronic Throttle Control daledurham New Member Introductions 1 01-20-2018 12:30 PM
Service Electronic Throttle Control?? HVAC Man Ram 1500 EcoDiesel General Discussion 9 02-06-2015 04:47 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome