Diesel RAM Forum banner

Anyone with UConnect Problems?

13305 Views 5 Replies 4 Participants Last post by  Anthony Savino
In the grand scheme of things, the problems described below are far less serious than what some of you are experiencing with CELs, catalytic converters, etc. Nonetheless, kind of irritating when the UConnect system on a very expensive truck malfunctions. Some of you might remember that late last year UConnect problems were cited as one of the more common customer (dis)satisfaction issues with Chrysler products. Chrysler attributed these problems to customers not knowing how to operate the UConnect system.

So here's the issue ('14 Laramie 4x4 crew, Uconnect 8.4a w/navigation activated, current UConnect software version):

Started truck this a.m. for the second trip of the day. Touchscreen on Uconnect system displayed the Ram log but basically hung up in the "boot" process. Put transmission in reverse, no rear view camera (still just a Ram logo). Backed out of drive, put transmission in drive, the rear view camera finally displayed and it stayed on for about 30-45 seconds, at which time the normal touchscreen display appeared.

BUT… although I could move between the different screens on the touchscreen (radio, media, settings, climate, navigation, phone, apps), all of the buttons on all of the screens were inactive. The navigation screen simply showed "activating navigation." This remained the case for the duration of my trip. Upon arriving at my destination, turned off the truck and opened the door. Restarted the vehicle. Same behavior. Went into take care of business, returned to the truck, and all systems then worked properly.

Called the dealer and they did not have any advice/thoughts on the problem. And, of course, they said there was nothing they could do if the truck was not exhibiting the problem when I bring it into the shop.

Anyone experiencing similar problems? If so, how were they resolved (if at all)?

See less See more
1 - 3 of 6 Posts
Great suggestion! Thanks!

Regarding Divemaster's post (above), yes--did an update last summer about 2 months after I took delivery. Pretty easy (unrelated issue: boggles my mind that there has not been a navigation map update for close to a year!).

My local service department was not of any help in answering my questions so I worked directly with Chrysler customer assistance. Here is an excerpt from the written response:

"This has occurred before. The Radio is stuck on the RAM's head splash screen. This is usually something that a strong recommendation to go the Dealership follows. What is a rare occurrence is the radio resolving itself. The vehicle more often then not will remain frozen on the logo and parts have to be replaced but in your case this seemed more like a software hiccup. If this happens in the future and you are able to go to the dealership while the issue is present, that would be recommended. This issue does not set off any trouble codes usually when they plug in the scan diagnostic tool and the issue is not happening. If it happens and goes away again I would most certainly reflash the vehicle."
See less See more
1 - 3 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.