Diesel RAM Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Just got back from Lunch and my MIL came on and stayed on. According to the Manual, this indicates a possible enigine control problem and needs system service. Contact Dealer as soon as possible.

Called dealer service and was told they can see the truck in 2 weeks. He asked if the truck was acting up or making funny noises. I told him it is new diesel, how do I know if the noises are 'funny'? Service with a smile on a $50K truck, eh??

I explained that I am going on a Road Trip and will require a replacement of like kind since this is a Warranty issue. Please have a truck ready for me when I bring it by. He then decided to transfer me to the Service Manager. I left a message and am curious to see how they 'work me in'.

Will keep you all informed once the problem has been diagnosed.:(
 

·
Registered
Joined
·
18 Posts
crap... ya let us know.. feeling ill right now.. and mine is still not even here..
 

·
Registered
Joined
·
350 Posts
Hopefully the problem isn't too serious and hopefully you get proper customer service. I'll keep my fingers crossed for you.

Be sure to come back and let us know how things go.
 

·
Registered
Joined
·
963 Posts
I expected that the dealer would be able to take a look at your vehicle much sooner than what they reported their.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
Ran the code and it has to do with lack of communication somewhere. Told me should be ok to drive, but leary of such advice as they do not know what communication is not working.

Seems to have less torque right now and the Remote Start is not working. Scheduled in later this week with a loaner. The Service folks have not seen any of these ED's yet, so this will be the test tube baby. Will let you know what they find out.

Good news is that I can get my recall taken care of, LOL.
 

·
Registered
Joined
·
173 Posts
Do you know the specific code? P#### or U#### assuming they are sticking with the standard codes?

regarding noises...Diesels talk to you, it just takes a while to hear and note the differences. I read something to this affect in one of the 2500 owners manuals that I had over the years. But certainly if it sounds different then something is going on. Even suttle sounds can alert you to potential problem.
 

·
Registered
Joined
·
4 Posts
My check engine came on after 1000 miles. Took it into dealer and was told that "sensor came unplugged". In and out in 10 mins. Just drove it to FL and added another 2000 miles without issue.
 

·
Registered
Joined
·
830 Posts
My check engine came on after 1000 miles. Took it into dealer and was told that "sensor came unplugged". In and out in 10 mins. Just drove it to FL and added another 2000 miles without issue.
Yea I've seen a couple out and about on the boards thats have strange issues like loose connectors. Like you said easy in and out, but I'm just wondering why are these connectors coming loose in the first place?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
Hey guys, they had some Software Flash needs/updates.

Flash update from 68211669AG to 68211669AH per RRT 14037
Also Diagnostics Improvements Flash 2243 for the DS 3.0L Diagnostic/System
Flash for RFH - 08P15182 Flash Update for Radio (Recall I believe)

Truck is running fine and all is well (just a bit of inconvenience).
 

·
Registered
Joined
·
963 Posts
Hey guys, they had some Software Flash needs/updates.

Flash update from 68211669AG to 68211669AH per RRT 14037
Also Diagnostics Improvements Flash 2243 for the DS 3.0L Diagnostic/System
Flash for RFH - 08P15182 Flash Update for Radio (Recall I believe)

Truck is running fine and all is well (just a bit of inconvenience).
Awesome, great to hear it's running great. How long did the whole flash process take?
 

·
Registered
Joined
·
18 Posts
Awesome, great to hear it's running great. How long did the whole flash process take?
Don't want to butt in, Mine took about 30 minutes they also reprogramed the ecm. I don't know if it made any difference but is seems to shift into 8th gear at 50mph now, it was about 55.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
It was in the shop for the day. Got a Rental Car in the morning and came back when done. 1st ED they have seen, so I am sure that they took some time to be sure:)
 

·
Registered
Joined
·
5 Posts
Mine came on at less than 900 miles, supposedly moisture in one of the sensor connections but the service manager didn't know which one. Haven't picked it up yet but will find out which one and what the code thrown was. Service manager stated it was probably a factory issue, that doesn't make me feel very comfortable.
 

·
Registered
Joined
·
412 Posts
Glad it was "nothing" and they fixed it. Darn computer things sure mess up often on all vehicles.

As for that dealer telling you they could look at it in two weeks...you did fine. I would be in jail after the violence.
 

·
Registered
Joined
·
1 Posts
Check engine light on

The problem probably has nothing to do with engine. Mine came on at 5800 k and it usually has to with pollution control such as sooted up sensor. As for the truck it's been great, on a recent trip we averaged 37 MPG. (Imperial gallons which is slightly bigger than US)
 

·
Registered
Joined
·
412 Posts
Chain - Welcome.

No intro but I read that mileage and realized you must be a "Canook". You now get a pass to speak in "clicks" instead of mpg.

Some can figure out kms per liter. I met one once.
 

·
Registered
Joined
·
77 Posts
Chain - Welcome.

No intro but I read that mileage and realized you must be a "Canook". You now get a pass to speak in "clicks" instead of mpg.

Some can figure out kms per liter. I met one once.
Lucky for you sir, our trucks come equipped with the tech to show you that 'Milage" in L/100km. Just go through your display menu and change it to see it from our perspective. It feels pretty good to see the Distance to empty sitting at 980km+ lol.
 
1 - 20 of 21 Posts
Top