Diesel RAM Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
In the past three months this light has come on 4 times. When it does I lose power and three times now I have had it towed in. I learned my lesson from trying to limp it to the dealer, too many close calls since you can't move out of the way for anything. This last instance I was in traffic, we slowed down for someone to turn off the road, traffic then accelerated, I attempted to with no power, looking down I saw the ETC light on again, when I looked up, a car was bearing down on me from behind. I could not do anything quickly except hit the flasher button, and they went around me. This issue has become a hazard to my safety and anyone else around me, or riding with me. My wife refuses to ride in the vehicle. I know I have hit the requirements for the lemon law, 4 times same issue in 3 months, vehicle down for over thirty days in 3 months. What do I do now? Dealer just wants to try and fix it again. Obviously no one knows what to do. 2016/1500 ecodiesel, 13500 miles, only had it 9 months.
 

·
Registered
Joined
·
1 Posts
In the past three months this light has come on 4 times. When it does I lose power and three times now I have had it towed in. I learned my lesson from trying to limp it to the dealer, too many close calls since you can't move out of the way for anything. This last instance I was in traffic, we slowed down for someone to turn off the road, traffic then accelerated, I attempted to with no power, looking down I saw the ETC light on again, when I looked up, a car was bearing down on me from behind. I could not do anything quickly except hit the flasher button, and they went around me. This issue has become a hazard to my safety and anyone else around me, or riding with me. My wife refuses to ride in the vehicle. I know I have hit the requirements for the lemon law, 4 times same issue in 3 months, vehicle down for over thirty days in 3 months. What do I do now? Dealer just wants to try and fix it again. Obviously no one knows what to do. 2016/1500 ecodiesel, 13500 miles, only had it 9 months.
similar problem. 2014. 32000 miles. first time, replaced sensor. three days later same problem. then they replaced injectors, rails and fuel filter. has been running great for 7 weeks and then same problem. in shop today - reflashed - on test drive same problem. call into chrysler.
 
1 - 4 of 4 Posts
Top