Diesel RAM Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Monday night I went to pick up my new 1500 Eco. I got the outdoorsman package with the cold weather group. I have always been a GM guy, loved the 5.3L gas motor for the 15 past years. As good as it is it has left me looking for more. I've always felt that Dodge's weakness lies in the electrical system. After driving he Eco I kinda fell in love. Convinced by my father-in-law, a long time Ram owner how great they are I pulled the trigger. Happy new Ram 1500 owner, or so I thought.... On the way home we stop for dinner, I use remote start from inside as it was about 10F outside. No issues. We get home by about 10pm, and park it in the drive. Awake to 5F in the morning. At 6am I try to use remote start, it does not work.... couple minutes later try again... nothing. Go outside, look at dash... Remote start deactivated... Hmmmm this is odd. Inset key and try to start the truck... It does nothing... when I turn the key to the run position it scrolls through all the warning lights and messages. When I turn the key to start the display reboots and the Ram Logo appears.... Go figure and electrical issue on a Dodge. Call the dealer to come pick it up.... When I call the dealer... wait for it.... THEY FIND NOTHING WRONG... basically say I don't' know how to start the truck... I told them to keep it, I don't want it back... I am perfectly able to press a button twice to active the remote start. Beyond that I explained a sequence of computer reboot and the 20 minutes I tried getting it to start trying both Fobs and numerous combinations of things. It never even turned over.... They assured me that nothing was wrong to come pick it up. I assured them I would not, they could keep looking or undo the deal. After 6 hours today I got a call that they found the issue, the smoking gun... Somehow the wrong battery was installed in the truck, a 755A battery v/s an 855A battery. Now I won't say that this couldn't cause the issue, it might, but that does not seem like a big enough difference on a new battery. But the system did seem to reboot like a dead/low battery, so maybe... They are delivering the truck to me this afternoon, hopefully all is well. No cold weather in site for the next 10 days so a true test is not in my near future. Anyone else heard of a TSB on the wrong battery?


UPDATE!!! It was 1F out today, Thursday morning. They delivered the truck last night, I ran around did some shopping and put about 40 miles on it with 3 stops. No Issues I was pretty happy. I parked it at 8:45pm. At 6AM today, while standing in the kitchen window, press the button on the fob 2x, horn honks, lights blink.... and wait for it... NOTHING. Grab my jacket and go outside. Same message, Remote start disabled. So I put the key in turn it to run, wait, turn it to Start and release to run, wait, wait wait... yep it will do nothing. This time the radio goes blank not the MFD in the dash. Call the dealer, song and dance and they confirm I'm not an idiot (like they implied the first time), the truck will not start... So they are coming back to pick it up again. I told them to keep it.... So god willing I'm no longer a Eco Owner.... For now at least... we will see if I can undo this deal... Good news is we are 2x closer to the Lemon Law...
 

·
Premium Member
Joined
·
476 Posts
Well thanks for the, uh, rant? I guess?
 

·
Registered
Joined
·
314 Posts
It does sound like an anomaly. Would you consider trying a different diesel ram unit, or has this experience turned you off the whole brand?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Maybe I don't belong on here...

I would love to have the truck, by all accounts they seem to be awesome trucks. I just made this my First ever off the lot, brand new, 0 mile, new car purchase. I did request the dealer get me the exact same truck. Maybe I'm expecting too much of a new truck to start on the only two days I've had it?.


If this is a rant than maybe I don't belong on this site.


I was hoping that maybe some had some answers or similar symptoms..
 

·
Registered
Joined
·
10 Posts
Sorry to hear about the cold starting issues but I am very interested in hearing how this turns out. I have been waiting for the temperatures to drop to see if there will be any negative comments on starting and general performance. Please keep us posted on how this goes down.
 

·
Registered
Joined
·
44 Posts
the difference in battery would likely mean little in normal temps, but then the temperature went and dropped.

It makes sense that the whole system goes fritz as well, its likely starving your organs and limbs of oxygen...
 

·
Registered
Joined
·
350 Posts
This is a sh*t story man. I hope that you are able to get a diesel Ram that does work. Would be a shame if you had to leave the brand because of a bad apple.

I'm curious to see how this works out for you. Keep us updated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
So I have been working with the dealer and they are trying to locate your replacement truck. there just aren't any replacement trucks that are the same or similar within a reasonable distance they are looking 500 to 600 miles out right now. In the meantime they are trying to repair the one I have. they were working with star on trying to figure out what is wrong their next suggestion is that the starter is bad. a new starter is 3 to 5 days out. They offered to pull one off of a truck on the lot. I declined and decided to wait for a brand new one just in case there is an issue with older units. I will keep everyone updated when I get my truck back next week.
 
1 - 9 of 9 Posts
Top